VTP vlan trunking

Thanks to http://www.nhatnghe.com/forum/showthread.php?t=242155

+ Tham khảo Bài VLAN TRUNKING để hiểu rỏ hơn
+ File LAB download.
+ CHUẨN BỊ : Ta xây dụng mô hình lab như hình trên.
+YÊU CẦU:
1. Server tạo 5 lan
– Ketoan VLAN10: 192.168.10.0 /24
– Nhansu VlAN 20: 192.168.20.0/24
– Giaovu VLAN 30: 192.168.30.0/24
2.Cấu hình telnet password 123 giữa các SW, Router
3. Đảm bảo VTP đồng bộ Vlan giữa các SW , PC1 ping thành công PC2
4. Đảm bảo PC3 Vlan 10 có thể ping thành công PC4 vlan 20//ko lam dc
5. Các PC có thể đi Internet//ko lam dc
– Mô tả quá trình thực hiện các bước trong bài lab

1. SW_A (server): ta chia vlan ra thành 3 Vlan và đặt hostname đặt ip cho 3vlan đó, gán các port tương ứng cho vlan.Mặc định trên Switch các cổng f0/1,f0/2,f0/3 thuộc Vlan1.
– Ta gán các port từ f0/4 -> f0/8 là thuộc Vlan10.
– Port từ f0/9 -> f0/20 thuộc Vlan20 và port từ f0/21 -> f0/24 thuộc Vlan30.
– Cấu hình Telnet không password.
– Thiết lập VTP version là 2, VTP domain là PHAMDANH.CO.CC, VTP mode là SERVER, password là 123.
– Lên Trunk cho cổng f0/1 (vì cổng này nối với SW_B)
2. SW_B (Transparent): có 2 cách để ta cấu hình nó đồng bộ với SW_A (server).
Cách 1: Bạn phải tạo Vlan bằng tay giống như cách tạo ở SW_A rồi sau đó bạn cấu hình VTP version là 2, VTP domain là PHAMDANH.CO.CC, VTP mode là TRANSPARENT, VTP password là 123, tiếp theo bạn lên trunk trên các cổng f0/1 nối với SW_A, f0/2 nối với SW_C.
Cách 2: Tôi thường chọn cách này bởi nó nhanh, Đầu tiên tôi cấu hình VTP version là 2, VTP domain là PHAMDANH.CO.CC, VTP mode là CLIENT, VTP password là 123, rồi lên trunk trên cổng f0/1 và f0/2 để cho đồng bộ Vlan, rồi cuối cùng tôi chuyển nó vể VTP mode là TRANSPARENT như yêu cầu.
– Các bước tiếp là gán port tương ứng vào các Vlan giống như SW_A.
3. SW_C (Client): Thiết lập VTP version là 2, VTP domain là PHAMDANH.CO.CC, VTP mode là CLIENT, password là 123.
– Lên Trunk cho các cổng f0/1 và f0/2.
– Gán port tương ứng vào các Vlan giống như SW_A .
4. Router: Cấu hình Telnet không password, vào cổng f0/0 no shut lên.
– Cấu hình Routing chia các subinterface: f0/0.1 (Vlan1), f0/0.2(Vlan10), f0/0.3(Vlan20), f0/0.4(Vlan30) .
THỰC HIỆN
1. SW_A:
– Đặt hostname, cấu hình Telnet mật khẩu 123
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname Sw_A
Sw_A(config)#enable password 123
Sw_A (config)#line vty 0 4
Sw_A (config-line)#password 123
Sw_A (config-line)#no login
Sw_A (config-line)#exit
Sw_A (config)# end
Chia 3 Vlan, Gán địa chỉ IP cho từng Vlan
Sw_A(config)#vlan 1
Sw_A (config)# exit
Sw_A(config)#interface vlan 1
Sw_A(config-if)#ip address 192.168.1.2 255.255.255.0
Sw_A(config-if)#no shutdown
Sw_A(config-if)# ip default-gateway 192.168.1.1
Sw_A(config-if)#end
——————————————-
Sw_A(config)#vlan 10
Sw_A(config-vlan)#exit
Sw_A(config)#interface vlan 10
Sw_A(config-if)#ip address 192.168.10.1 255.255.255.0
Sw_A(config-if)#no shutdown
——————————————–
Sw_A(config)#vlan 20
Sw_A(config-vlan)#exit
Sw_A(config)#interface vlan 10
Sw_A(config-if)#ip address 192.168.10.2 255.255.255.0
Sw_A(config-if)#no shutdown
———————————————
Sw_A(config)#vlan 30
Sw_A (config)# exit
Sw_A(config)#interface vlan 20
Sw_A(config-if)#ip address 192.168.20.2 255.255.255.0
Sw_A(config-if)#no shutdown
———————————————
Gán port tương ứng vào vlan10:
Sw_A(config)#interface range f0/4-8
Sw_A(config-if-range)#switchport mode access
Sw_A(config-if-range)#switchport access vlan
Sw_A(config-if-range)#switchport access vlan 10
Gán port tương ứng vào vlan20:
Sw_A(config)#interface range f0/9-20
Sw_A(config-if-range)#switchport mode access
Sw_A(config-if-range)#switchport access vlan
Sw_A(config-if-range)#switchport access vlan 20
Gán port tương ứng vào vlan10:
Sw_A(config)#interface range f0/20-21
Sw_A(config-if-range)#switchport mode access
Sw_A(config-if-range)#switchport access vlan 30
C. Cấu hình VTP mode:
Sw_A(config)#vtp version 2
Sw_A(config)#vtp mode server
Device mode already VTP SERVER.
Sw_A(config)#vtp domain phamdanh.co.cc
Changing VTP domain name from NULL to phamdanh.co.cc
Sw_A(config)#vtp password 123
Setting device VLAN database password to 123
Sw_A(config)#end
D. Kích hoạt trunking trên cổng Fa0/1 và cho phép tất cả các VLAN qua trunk:
Sw_A(config)#interface f0/1
Sw_A(config-if)#switchport mode trunk
Sw_A(config-if)#switchport trunk allowed vlan all
Ngoài ra nếu SW có hỗ trợ đóng gói kiểu isl (hoặc dot1q) để đi qua đường trunk¬SW(config-if)#switchport trunk encapsulation isl
Đọc bài VLAN TRUNKING để hiểu rỏ hơn
E. Show vlan để xem kết quả

Sw_A(config)#show vlan
VLAN Name Status Ports
—- ——————————– ——— ——————————-
1 default active Fa0/2, Fa0/3, Gig1/1, Gig1/2
10 ketoan active Fa0/4, Fa0/5, Fa0/6, Fa0/7,Fa0/8
20 nhansu active Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
30 giaovu active Fa0/21, Fa0/22, Fa0/23, Fa0/24
1002 fddi-default act/unsup
…………
F. Show vtp để xem kết quả
Sw_A#show vtp status
VTP Version : 2
Configuration Revision : 9 //số revision number
Maximum VLANs supported locally : 255Number of existing VLANs : 9
VTP Operating Mode : Server // Switch hoạt động ở chế độ client
VTP Domain Name : phamdanh.co.cc // Switch thuộc domain phamdanh.co.cc
VTP Pruning Mode : Disabled
VTP V2 Mode : Enabled
VTP Traps Generation : Disabled
MD5 digest : 0x6D 0×69 0xC6 0xC4 0×07 0xD2 0×06 0×71
Configuration last modified by 192.168.1.10 at 3-1-93 01:36:32
Local updater ID is 192.168.1.1 on interface Vl1 (lowest numbered VLAN interface found)

Lưu ý: Revision number là một trong những thông số quan trọng của VTP. Mỗi khi VTP server thay đổi VLAN database thì sẽ tăng giá trị revision lên 1 và thực hiện quảng cáo VLAN database này. Các thiết bị có số revision nhỏ hơn phải chấp nhận VLAN database có số revision lớn hơn.
– Nếu VTP server xoá bỏ tất cả các VLAN & có số revision cao nhất thì các thiết bị khác cũng sẽ bị xoá VLAN.


2. SW_B(Transparent):

– A. Đặt hostname, cấu hình Telnet không mật khẩu (làm tương tự như SW_A)
+ Áp dụng cách 2:
B. Cấu hình VTP mode là CLIENT cho nó đồng bộ rồi chuyển qua mode TRANSPARENT
Sw_A(config)#vtp version 2
Sw_A(config)#vtp mode server
Device mode already VTP Client.
Sw_A(config)#vtp domain phamdanh.co.cc
Changing VTP domain name from NULL to phamdanh.co.cc
Sw_A(config)#vtp password 123
Setting device VLAN database password to 123
Sw_A(config)#end
C. Kích hoạt trunking trên cổng f0/1, f0/2 và cho phép tất cả các VLAN qua trunk:
Sw_A(config)#interface f0/1
Sw_A(config-if)#switchport mode trunk
Sw_A(config-if)#switchport trunk allowed vlan all
– Làm tương tương tự cho cổng f0/2
D. Show vlan để xem kết quả đã đồng bộ từ SW_A
Sw_A(config)#show vlan

VLAN Name Status Ports
—- ——————————– ——— ——————————-
1 default active Fa0/2, Fa0/3, Gig1/1, Gig1/2
Fa0/4, Fa0/5, Fa0/6, Fa0/7 Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
10 ketoan active
20 nhansu active
30 giaovu active
1002 fddi-default act/unsup
…………
E. Chuyển VTP mode lại thành TRANSPARENT (như câu B)
F. Gán các port tương ứng vào các VLAN ( câu lệnh làm tương tự như SW_A)
G. Show vlan để xem kết quả sau khi đã gán các port tương ứng vào các VLAN

Switch#show vlan
VLAN Name Status Ports
—- ——————————– ——— ——————————-
1 default active Fa0/3, Gig1/1, Gig1/2
10 ketoan active Fa0/4, Fa0/5, Fa0/6, Fa0/7,Fa0/8
20 nhansu active Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
30 giaovu active Fa0/21, Fa0/22, Fa0/23, Fa0/24
1002 fddi-default act/unsup
………………
3.SW_C(Client)
– Ta làm tương tự như ở trên
– Đầu tiên ta cấu hình VTP mode Client
– Lên trunk cho các cổng f0/1 và f0/2
– Gán port tương ứng vào các Vlan

4. ROUTER

+ Trong trường hợp dùng giao thức dot1q, bạn cần đảm bảo native VLAN ở hai đầu kết nối trunk là giống nhau (mặc định trên switch 2900XL là VLAN 1).
c2600(config-subif)#encapsulation dot1Q 1 ?
native Make this is native vlan <cr>
c2600(config-subif)#encapsulation dot1Q 1 native
c2600(config-subif)#encapsulation isl 2
(hay bằng dot1q: c2600(config-subif)#encapsulation dot1Q 2)

1. Cấu hình Routing trên subinterface

– Ở đây tôi sử dụng dot1Q
Router(config)#interface f0/0
Router(config)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
B. Kích hoạt trunking trên sub-interface F0/0.1, F0/0.2, F0/0.3, F0. và encapsulation bằng dotQ1
Router(config)#interface f0/0.1
Router(config-subif)#encapsulation dot1Q 1 ?
native Make this as native vlan
<cr>
Router(config-subif)#encapsulation dot1Q 1 native
Router(config-subif)#ip addres 192.168.1.1 255.255.255.0
Router(config-subif)#exit
—————-
Router(config)#interface f0/0.2
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip addres 192.168.10.1 255.255.255.0
Router(config-subif)#exit
———————–
Router(config)#interface f0/0.3
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip addres 192.168.20.1 255.255.255.0
Router(config-subif)#exit
————————————
Router(config)#interface f0/0.4
Router(config-subif)#encapsulation dot1Q 30
Router(config-subif)#ip addres 192.168.30.1 255.255.255.0
Router(config-subif)#exit

5. Các PC có thể đi Internet
– Ta giả lập ISP là GOOGLE bằng cách gắn thêm Router(internet) mới nối với Router củ
Đặt lớp mạng là 8.8.8.0/24
+ Thực hiên câu lệnh đặt địa chỉ IP cổng f0/1 trên Router củ:
Router(config)#interface f0/1
Router(config)#ip address 8.8.8.9 255.0.0.0
Router(config)#no shutdown
Cấu hình NAT để ra ngoài Internet
Router(config)#access-list 1 permit any
Router(config)#ip nat inside source list 1 interface f0/1 overload
Router(config)#interface f0/0 // cổng nối với nội bộ
Router(config-if)#ip nat inside
Router(config)#interface f0/1 // cổng nối với Wan
Router(config-if)#ip nat outside
+ Thực hiên câu lệnh đặt địa chỉ IP cổng f0/1 trên Router(internet) mới
Internet(config)#interface f0/1
Internet(config)#ip address 8.8.8.9 255.0.0.0
Internet(config)#no shutdown
Tạo Default route giả lâp đang là Google trỏ về khách hàng
Internet(config)#ip route 0.0.0.0 0.0.0.0 8.8.8.9
5. IP trên các PC
PC 1 thuộc VLAN 30
IP: 192.168.30.100
SN: 255.255.255.0
DG: 192.168.30.1
PC 2 thuộc VLAN 30
IP: 192.168.30.101
SN: 255.255.255.0
DG: 192.168.30.1
PC 3 thuộc VLAN 10
IP: 192.168.10.100
SN: 255.255.255.0
DG: 192.168.10.1
PC 4 thuộc VLAN 20
IP: 192.168.20.100
SN: 255.255.255.0
DG: 192.168.20.1
6.TEST:
+ Kiểm tra ra ngoài internet bằng cách: lên PC3 ping 8.8.8.8
Pinging 8.8.8.8 with 32 bytes of data:
Reply from 8.8.8.8: bytes=32 time=25ms TTL=254 // thành công xem như đã ra net
….
+ Telnet vào Router
PC>telnet 192.168.10.1
Trying 192.168.10.1 …Open
User Access Verification
Password:
Router>en
Password:
Router#
+ Cấu hình Telnet vào Switch
PC>telnet 192.168.10.2
Trying 192.168.10.2 …Open
User Access Verification
Switch>en
Password:
Switch#
THE END

Biên soạn: PhạmDanh